Cette erreur indique : Le programme spécifié nécessite une version plus récente de Windows.

Veuillez installer et utiliser Driver Genius sur un système d'exploitation compatible.

La dernière version de Driver Genius est compatible avec Windows XP, Windows Vista, Windows 7, Windows 8, Windows 8.1 et 10 entièrement mis à jour